Mac Version of iMovie Gets an Update – Now Supports Older Macs

Mac Version of iMovie Gets an Update – Now Supports Older Macs

If you have an older Mac and were bummed because the newest version of iMovie, introduced alongside Mavericks, wasn’t compatible with your machine, we may some good news for you. Apple has updated the Mac version of iMovie, and with it comes fixes allowing the use of the video editing app with older Macs.

iMovie_Mac_screenshot

The change log doesn’t list which “older video cards” are now supported, but if you’ve bought iMovie in the past and found you couldn’t use it on your older Mac, it’s worth a shot to update and try it out.

What’s New in Version 10.0.1

  • Allows iMovie to be installed on computers with some older video cards
  • Addresses reliability issues when updating projects and events from previous versions of iMovie

iMovie is available in the App Store. [DIRECT LINK]

  1. 517319 515544hey great website i will definaely come back and see once again. 580595

  2. 794867 704093Nice blog here! following reading, i decide to buy a sleeping bag ASAP 741753

  3. 992796 459363Hi there! Good stuff, please do tell me when you lastly post something like this! 724781

  4. 229406 91869Music began playing any time I opened this site, so frustrating! 524663

  5. 684811 193419Some truly good stuff on this internet site, I love it. 682786

  6. 147094 173662I likewise believe thus, perfectly pent post! . 567704

  7. 102770 284816I like this weblog its a master peace ! Glad I detected this on google . 896680

  8. 288206 25406This site is my inhalation, actually great layout and Perfect written content. 226162

  9. 548382 440050Hey this is kinda of off subject but I was wanting to know if blogs use WYSIWYG editors or should you have to manually code with HTML. Im starting a blog soon but have no coding experience so I wanted to get advice from someone with experience. Any assist would be greatly appreciated! 541442

Leave a Reply

Your email address will not be published.