• Home
  • macOS
  • News
  • macOS Monterey 12.3 Update Bricking Macs That Have Had Their Logic Boards Replaced

macOS Monterey 12.3 Update Bricking Macs That Have Had Their Logic Boards Replaced

macOS Monterey 12.3 Update Bricking Macs That Have Had Their Logic Boards Replaced

The most recent macOS Monterey update, version 12.3, is said to be bricking Macs that have had their logic boards replaced, says numerous reports posted on social media and Apple’s support forums.

As laid out in an Apple Developer forum thread, some users that have tried to update their Mac to macOS 12.3 from macOS 12.2.1 or earlier are met with errors, endless restart loops, and possibly a completely bricked Mac. The report appears to be limited to new 14-inch and 16-inch MacBook Pros that have had their logic boards replaced.

There is a firmware bug in Mac OS 12.3 that renders the update impossible to install on any 2021 14 or 16 inch MacBook Pro that has had it’s logic board replaced.

The cycle is:

You try to upgrade, the upgrade will fail but recovery to handle it correctly, you’ll reboot still on 12.2.1 but with a report a problem dialogue informing you of an iBoot Panic
You’ll try to upgrade again. This time, the iBoot FW will corrupt. You’ll see the apple icon flash on boot 5-6 times before seeing the exclamation mark symbol telling you recovery is needed.
You can try and revive using a second Mac with Apple Configurator 2. This will fail, because it tries to load the 12.3 firmware from the IPSW, in either DFU or Recovery mode.
The only way to get things running again is to manually download the 12.2.1 IPSW and use Apple Configurator 2, with the Mac in DFU mode, to load the revive image. This will update the firmware of iBoot, and the recovery image to a working build. The Mac will then restore 12.2.1’s OS, keeping your data upon finishing.

Users are said to be presented with two possible outcomes. It either leaves the Mac in a bricked, unusable state or the Mac completes the update process and reboots but doesn’t update and displays an “iBoot Panic” message.

Users report similar issues in a Reddit thread. One user reports, “When I attempt to upgrade to 12.3 on a 2021 M1 14-inch MacBook, the entire download and then upgrade sequence completes (30 or 40 minutes in upgrade sequence) and when it reboots has not upgraded and is still on 12.2.1.”

When the Mac doesn’t boot up after the update process, users must put their Mac into DFU and revive it manually. However, this requires a second Mac to be handy to use Apple Configurator 2. Users with no second Mac are faced with a visit to the Genius Bar for assistance.

One Reddit user has offered some advice:

Any attempts to get 12.3 on your mac will fail with that error.

You should be able to get into DFU though – wait until you’re on the exclamation mark screen after a few flashes, then do the DFU key sequence. Configurator will let you try a revive in recovery mode though, but not sure if that works – I assume that’s your 21 error. You should get a 2006 error when trying in DFU mode.

The second time I tried a normal in system upgrade, the screen refused to show anything as a result of the firmware failure – but it still appeared in Configurator and the DFU key sequence still worked.

Apple offers instructions for how to revive an Apple silicon Mac here and Intel-based Mac instructions can be found here. Both processes require Apple Configurator 2. Apple has so far not commented or acknowledged the specific issue bricking Macs attempting to update to macOS 12.3. We’ll keep you posted in this space.

(Via MacRumors)